Linux
Reply Return

หัวข้อ : ติดตั้ง slirp แต่ compile ไม่ผ่าน

ข้อความว่า
ชื่อ: ปู
ส่งมาเมื่อวันที่ : 27 ตุลาคม, 1998 at 16:35:14 [ ด้วย IP : 192.100.77.6 ]
หัวข้อ : ติดตั้ง slirp แต่ compile ไม่ผ่าน
ด้วยข้อความที่ว่า:
ผมใช้ linux 5.01 เป็น server ในระบบเครือข่าย lan ต่อ internet
ผ่าน ethernet interface ของ router (ยี่ห้อ cisco) ต้องการใช้
โปรแกรม slirp เพื่อ remote ผ่าน modem มาจากที่อื่น
compile ไม่ผ่านครับ error ดังนี้ ครับ
gcc -I. -I. -DUSE_PPP -g -O -O2 -c ./ppp/pppdfncs.c
In file included from slirp.h:264,
from ppp/ppp.h:27,
from ppp/pppd.h:29,
from ./ppp/pppdfncs.c:39:
ppp.p:21: conflicting types for `logwtmp'
/usr/include/utmp.h:53: previous declaration of `logwtmp'
make: *** [pppdfncs.o] Error 1
ผู้รู้ช่วยหน่อยครับ ขอบคุณเป็นอย่างสูง

ผู้ตอบคนที่ 1
ชื่อ: Jonix
ส่งเมื่อวันที่ : 27 ตุลาคม, 1998 at 22:25:09 [ ด้วย IP 203.148.200.249 ]
หัวข้อ : Re: ติดตั้ง slirp แต่ compile ไม่ผ่าน
ตอบว่า :
เห็นมี binary พร้อมใช้งาน (สภาพดี อวทม) ที่ http://blitzen.canberra.edu.au/slirp/
ไป d/l มาใช้ได้เลยครับ

กรณีมี access server ดีๆใช้ก็ไม่น่าใช้ slirp นะครับ
เซต cisco ให้เป็น radius client จะดีกว่านะครับ
เอา radius server จาก ftp://ftp.cistron.nl
มา install บน linux

ส่วนการเซต cisco ก็ลองดูใน manual นะครับ
หรือดูที่ http://www.cisco.com ก็ได้ ไม่ยากๆ


ผู้ตอบคนที่ 2
ชื่อ: น้อย
ส่งเมื่อวันที่ : 28 ตุลาคม, 1998 at 22:04:30 [ ด้วย IP 202.44.130.163 ]
หัวข้อ : Re: ติดตั้ง slirp แต่ compile ไม่ผ่าน
ตอบว่า :
สนใจ radius Server ครับ จะต้องไป Download File ชื่ออะไรมาครับ
ขอบคุณครับ

ท่านผู้รู้ กรุณาช่วยตอบวิธีแก้ปัญหาให้หน่อยครับ ขอบคุณมากครับ :

ชื่อ :
E-Mail :
หัวข้อ :
ข้อความว่า :