Linux
Reply Return

หัวข้อ : Java for Linux

ข้อความว่า
ชื่อ: Mid
ส่งมาเมื่อวันที่ : 23 มิถุนายน, 1998 at 17:44:20 [ ด้วย IP : 203.155.134.1 ]
หัวข้อ : Java for Linux
ด้วยข้อความที่ว่า:
จะต้องdownload ที่ไหนครับ เห็นมีแต่ของ sun sparc

ผู้ตอบคนที่ 1
ชื่อ: pruet
ส่งเมื่อวันที่ : 23 มิถุนายน, 1998 at 19:34:35 [ ด้วย IP 203.150.223.71 ]
หัวข้อ : Re: Java for Linux
ตอบว่า :
ไปที่ องค์การดำตก ซิครับ
http://www.blackdown.org
ซิครับ จะมี Linux java porting project อยู่นะครับ
try

ผู้ตอบคนที่ 2
ชื่อ: Mid
ส่งเมื่อวันที่ : 24 มิถุนายน, 1998 at 15:17:58 [ ด้วย IP 168.120.254.30 ]
หัวข้อ : Re: Java for Linux
ตอบว่า :
เลือกตัวไหนดีล่ะครับ i386 หรือเปล่าเอ่ยไม่แน่ใจครับ

ผู้ตอบคนที่ 3
ชื่อ: pruet
ส่งเมื่อวันที่ : 24 มิถุนายน, 1998 at 19:56:37 [ ด้วย IP 203.150.223.71 ]
หัวข้อ : Re: Java for Linux
ตอบว่า :
คำแนะนำนะครับ
ถ้าคุณจะเขียน Applet เพื่อ run บน web browser ควรใช้ Version 1.0.2 นะครับ เพราะว่า Web Browser บางตัว(เช่น Netscape ) ไม่ Support java 1.1.x (Netscape ออก JRE 1.1 Runtime support for Netscape 4.0 แล้ว แต่ว่ายังเป็น Beta version อยู่ แล้วพอผมลอง Netscape ก็ hang ไปเลย)
ถ้าคุณต้องการเขียนโปรแกรมโดยใช้ Java หรือเขียน Application โดยใช้ Java ก็ใช้ 1.1 ไปเลยครับ ตอนนี้ออกถึง 1.1.6 แล้ว แต่ว่ายังไม่ค่อยสมบูรณ์ เอาแถว 1.1.5 ไปก่อนก็ได้ครับ ถัดมา ก็เลือก i386 ถูกแล้วละครับ (นอกจากว่าเครื่องของคุณจะเป็น Alpha หรือว่า PPC ก็อีกเรื่องหนึ่ง) แล้วทีนี้ ก็ต้องดูว่าเครื่องคุณใช้ glibc หรือว่า libc5-6 นะครับ ถ้าเป็น distribution ใหม่ ๆ จะมี glibc ให้ (เช่น redhat 5 ) ถ้าจะให้ save เอาตัว libc ไปใช้ก่อนก็ได้ครับ
ข้างในจะมี subversion อยู่ให้เอาที่เลขมากที่สุดนะครับ ข้างในอาจจะมี file ให้เลือกหลายคัว แต่ละตัวก็มีความหมายดังนี้นะครับ
i18n.xxxxxxxxxxxxxx เป็นชุดพัฒนาสำหรับการทำ internationalization นะครับ
jdk.xxxxxxx เป็น Development Kit นะครับ จะมี runtime + compiler + debuger + etc. นะครับ ควรจะ download ชุดนี้นะครับ
jre.xxxxx เป็น Runtime environment นะครับ มีแต่ runtime + etc. นิดหน่อย ใช้พัฒนาไม่ได้นะครับ

และบาง version อาจจะต้อง download file ที่ชื่อว่า xxx.xxx.comman.xx.xx มาด้วยนะครับ แต่ไม่เสมอไป

ถ้าคุณใช้ Redhat ก็ควรจะเอาชุดที่เป็น rpm มาเลยนะครับ ถ้าไม่มีก็ค่อยเอา tgz ส่วน distribution อื่น ก็ tgz ตามระเบียบ

ขอให้สนุกครับ


ผู้ตอบคนที่ 4
ชื่อ: Mid
ส่งเมื่อวันที่ : 25 มิถุนายน, 1998 at 16:17:36 [ ด้วย IP 203.155.134.1 ]
หัวข้อ : Re: Java for Linux
ตอบว่า :
คือผมจะลง icq for linux น่ะครับ ถ้ารู้ก็ช่วยแนะนำด้วยก็แล้วกันครับ เคย เขียน java แต่บน pc

ผู้ตอบคนที่ 5
ชื่อ: pruet
ส่งเมื่อวันที่ : 25 มิถุนายน, 1998 at 19:32:29 [ ด้วย IP 203.150.223.71 ]
หัวข้อ : Re: Java for Linux
ตอบว่า :
ถ้าจำไม่ผิดต้องใช้ V1.1.5 ขึ้นไปนะครับ แต่มันใช้ไทยไม่ได้นะครับ ผมเคยลองแล้ว ส่ง Message ได้อย่างเดียวอีกต่าง ๆ (Chat, etc. ไม่ได้) ถ้ายังเป็นตัวที่ผมเคยใช้นะครับ มันก็ทำได้แค่นี้แหละครับครับ

ท่านผู้รู้ กรุณาช่วยตอบวิธีแก้ปัญหาให้หน่อยครับ ขอบคุณมากครับ :

ชื่อ :
E-Mail :
หัวข้อ :
ข้อความว่า :

 

Thai Net Home