Linux
Reply Return

หัวข้อ : mount cd rom ไม่ได้

ข้อความว่า
ชื่อ: lek
ส่งมาเมื่อวันที่ : 26 พฤศจิกายน,2001 at 21:14:58 [ ด้วย IP : 203.146.145.243 ]
หัวข้อ : mount cd rom ไม่ได้
ด้วยข้อความที่ว่า:
ผมใช้ redhat 7.2 ครับ เมื่อ install เสร็จแล้วกลับ mount cd rom ไม่ได้
ฟ้อง error ว่า " Could not mount device The reported error was.
mount / dev/cdrom is not a valid block device.

ผู้ตอบคนที่ 1
ชื่อ: มือใหม่
ส่งเมื่อวันที่ : 26 พฤศจิกายน,2001 at 22:45:19 [ ด้วย IP 203.146.156.100 ]
หัวข้อ : Re: mount cd rom ไม่ได้
ตอบว่า :
ขอรายละเอียดหน่อยจิครับ ... ตอน boot redhat เจอ cdrom รึป่าว ถ้าเจอ ก็ลองเชค link /dev/cdrom อาจจะ สร้างไม่ตรงกับ device จริง ๆ น่ะครับ IDE ตัวแรก จะเป็น /dev/hda ตัวที่ 2 เป็น /dev/hdb
ที่ primary IDE controller ซึ่งสำพันธ์กับ Master และ Slave และ ตัวที่ 3 และ 4 ก็จะเป็น
/dev/hdc และ /dev/hdd ที่ secondary IDE controller ตามลำดับ ลองดูซิครับว่า CDROM คุณต่ออยู่กับ IDE ไหน แล้ว เปลี่ยน link ที่สร้างไปที่ device ตัวนั้น เช่น ถ้า CDROM คุณ ต่ออยู่กับ secondary IDE controller และเป็น slave ก็ไปที่ cd /dev แล้วสร้าง linkด้วยคำสั่ง ln -s /dev/hdd cdrom แต่ก่อนสร้ง ควรลบ link เดิมก่อน แต่ถ้า ใส่ CDROM 2 ตัว อาจ link เป็นชื่ออื่น เช่น ln -s /dev/hdd cdrw จากนั้นก็ mount device ที่เรา ทำ link ไว้
เช่น munt -t iso9660 /dev/cdrw /mnt/cdrw ลองดูน่ะ

ผู้ตอบคนที่ 2
ชื่อ: wiwat
ส่งเมื่อวันที่ : 01 ธันวาคม,2001 at 18:05:57 [ ด้วย IP 203.148.159.38 ]
หัวข้อ : Re: mount cd rom ไม่ได้
ตอบว่า :
ลองสร้าง link ใหม่นะครับโดยใช้คำสั่ง ln
สร้าง link ไว้ใน dev/ นี่ล่ะครับ ให้กำหนด link ไปที่
dev/hd(อะไรก็แล้วแต่ตามที่ linux เห็นว่าเป็น devของ cdrom รึเปล่า ชื่อ dev จะเป็น iso9660 นะครับ แล้วลองใช้คำสั่ง mount -t iso9660 /dev/cdrom /mnt/cdrom
ลองดู

ผู้ตอบคนที่ 3
ชื่อ: nUm
ส่งเมื่อวันที่ : 03 ธันวาคม,2001 at 18:48:03 [ ด้วย IP 202.183.166.42 ]
หัวข้อ : Re: mount cd rom ไม่ได้
ตอบว่า :
ของผมก็เป็นเหมือนกัน
ลองดูที่ dmesg
มันจะมีการ check ความเร็วของ ide1 แล้วก็ error
ผมเคยทำให้มัน mount cdrom ได้โดยการ
แก้ไขไฟล์ fstab เอา kudzu ออกจากบรรทัด cdrom
แต่พอลงใหม่อีกครั้งทำแบบเดิม ก็ยัง mount ไม่ได้อยู่ดี เลยไม่ทราบสาเหตุ
ส่วนเรื่องการ mount ผิด
ตัดประเด็นนี้ไปได้เลยครับ



ผู้ตอบคนที่ 4
ชื่อ: nUm
ส่งเมื่อวันที่ : 18 ธันวาคม,2001 at 10:27:47 [ ด้วย IP 202.183.134.68 ]
หัวข้อ : Re: mount cd rom ไม่ได้
ตอบว่า :
ใช้คำสั่ง

depmod -ae

แล้วจึงจะ mount cdrom ได้
และให้เพิ่มคำสั่งนี้ไว้ในแฟ้ม rc.local


ผู้ตอบคนที่ 5
ชื่อ: พี่แดง
ส่งเมื่อวันที่ : 14 พฤศจิกายน,2002 at 12:15:45 [ ด้วย IP 202.129.5.167 ]
หัวข้อ : Re: mount cd rom ไม่ได้
ตอบว่า :
ปัญหานี้ผมก็กำลังเป็นอยู่ ทำการmnt/CD-ROM ไม่ได้
จะแก้ก็เพิ่งเข้ามาใช้งาน อยากทราบว่าจะแก้ไขโดยใช้คำสั่งบน KDE Desktop ได้ไหม ถ้าได้กรุณาบอกด้วยครับ จะเป็นพระคุณอย่างสูง

ท่านผู้รู้ กรุณาช่วยตอบวิธีแก้ปัญหาให้หน่อยครับ ขอบคุณมากครับ :

ชื่อ :
E-Mail :
หัวข้อ :
ข้อความว่า :