Linux
Reply Return

หัวข้อ : Radius

ข้อความว่า
ชื่อ: นาจ
ส่งมาเมื่อวันที่ : 27 กรกฎาคม, 1998 at 00:14:47 [ ด้วย IP : 203.154.20.39 ]
หัวข้อ : Radius
ด้วยข้อความที่ว่า:
ไม่รู้ตั้งหัวข้อถูกหรือเปล่า แต่..คือ สมมุติ ผมมี router cissco2511 อยู่ตัวนึง Linux อยู่ตัวนึง ต่อกันอยู่บน LAN แล้วผมอยากให้เวลาโทรเข้า
ที่ router แล้วสามารถ login เข้าที่ linux ได้เลยโดยใช้บัญชีของ linux เช่น
Login : user1@linux.com
Passwd : xxxx
ผมต้องทำอย่างไร ?
1. ที่ linux ผมใช้ slackware 2.0.30 ต้องคอมไพล์เคอร์เนลใหม่ หรือไม่ แล้วต้องเลือกอะไร หรือ ต้องใช้ 2.0.33 ขึ้นไป
......
2. ที่ router ต้องเซ็ต อะไรเพิ่มเติมหรือไม่
2.1 เพิ่มที่ hosts table ของ router ให้มองเห็น IP ของ Linux อย่างเดียวพอไหม ถ้าไม่ใช่
2.2 การเซ็ต router (cisso2511) อย่างละเอียด ตอนนี้มีแต่ตัวไม่มีอะไรทั้งนั้น (คู่มือ,ผู้ขาย,...) มีแต่ passwd


ถ้าหากท่านจะกรุณา ผมมีคำถามอื่น ๆ อีกมากมายที่อยากจะเรียนถามด้วยวาจา
ขอบคุณครับ
นาจ
nart@earthling.net
UIN 3048711


ผู้ตอบคนที่ 1
ชื่อ: mhz
ส่งเมื่อวันที่ : 06 กันยายน, 1998 at 02:03:05 [ ด้วย IP 203.144.244.106 ]
หัวข้อ : Re: Radius
ตอบว่า :
Mail มาคุยกันก่อนได้ไหมครับ
รายละเอียดแค่นี้ไม่พอครับ
(ไม่เก่งแต่อยากช่วย)

ผู้ตอบคนที่ 2
ชื่อ: power
ส่งเมื่อวันที่ : 08 มีนาคม, 1999 at 12:23:00 [ ด้วย IP 203.154.7.4 ]
หัวข้อ : netconfig
ตอบว่า :
ผมใช้ Linux sis อยู่ครับแล้วผมทำการ Copy จาก Hard ต่อ Hard เมืิ่อก่อนก็ใช้ได้ดี
แต่พอตอนหลังๆ ผมไม่ทราบว่าเป็นอะไร Copy แล้วไป Set Netconfig ไม่ได้ครับ ไม่ทราบว่า
ท่านใดจะให้ความกรุณาตอบปัญหานี้ได้บ้างครับ...ขอคุณมาก

ผู้ตอบคนที่ 3
ชื่อ: networker
ส่งเมื่อวันที่ : 26 กรกฎาคม, 1999 at 08:52:31 [ ด้วย IP 152.102.10.237 ]
หัวข้อ : Re: Radius
ตอบว่า :
Router Configuration

aaa new-model
aaa authentication login default local radius enable
aaa authentication login norad enable
aaa authentication ppp default if-needed local radius
aaa accounting delay-start
aaa accounting network default start-stop radius
enable password xxx
!
username xxx password xxx
ip subnet-zero
no ip finger
ip tcp path-mtu-discovery
!
ip address-pool local
multilink virtual-template 1
virtual-profile virtual-template 1
virtual-profile aaa
!
interface Ethernet0
ip address x.x.x.x x.x.x.x
no ip directed-broadcast
!
interface Virtual-Template1
ip unnumbered Ethernet0
no ip directed-broadcast
peer default ip address pool default
ppp authentication pap
ppp multilink
multilink load-threshold 1 outbound

interface Group-Async1
ip unnumbered Ethernet0
no ip directed-broadcast
encapsulation ppp
ip tcp header-compression passive
timeout absolute 480 0
dialer in-band
dialer idle-timeout 3600
dialer-group 1
async default routing
async dynamic routing
async mode interactive
peer default ip address pool default
no fair-queue
no cdp enable
ppp max-bad-auth 3
ppp authentication pap
ppp multilink
group-range 1 60
hold-queue 10 in
!
ip classless
ip local pool default x.x.x.x x.x.x.x
ip route 0.0.0.0 0.0.0.0 255.255.255.255
radius-server host x.x.x.x
radius-server key

line con 0
login authentication norad
transport input none
line 1 16
autoselect during-login
autoselect ppp
modem InOut
autocommand ppp
transport input all
autohangup
line aux 0
login
line vty 0
exec-timeout 1000 0
password xxx
login authentication vty
!
end

e-mail to me if you're not clear.


ท่านผู้รู้ กรุณาช่วยตอบวิธีแก้ปัญหาให้หน่อยครับ ขอบคุณมากครับ :

ชื่อ :
E-Mail :
หัวข้อ :
ข้อความว่า :