Linux
Reply Return

หัวข้อ : ยังเซทการ์ด network pci ไม่ได้เลยครับ .....

ข้อความว่า
ชื่อ: k
ส่งมาเมื่อวันที่ : 23 ธันวาคม, 1998 at 17:43:25 [ ด้วย IP : 203.146.13.37 ]
หัวข้อ : ยังเซทการ์ด network pci ไม่ได้เลยครับ .....
ด้วยข้อความที่ว่า:
จากที่คุณเด็กน้อยกับพี่จ้อนบอกให้ลองอีดิท ne.c กับ insmod ne2k-pci นี่ผมลองแล้วนะครับ แต่มันก็บอกมาแบบนี้อ่ะคับ

/lib/modules/2.0.36/net/ne2k-pci.o: unresolved symbol ei.open
/lib/modules/2.0.36/net/ne2k-pci.o: unresolved symbol ethidevPinit
/lib/modules/2.0.36/net/ne2k-pci.o: unresolved symbol ei_interrupt
/lib/modules/2.0.36/net/ne2k-pci.o: unresolved symbol NS8390_init
/lib/modules/2.0.36/net/ne2k-pci.o: unresolved symbol ei_close

ตอนนี้แอดเดรสอยู่ที่ 0x400 อ่ะครับ ลอง insmod ne2k-pci io=0x400 irq=9 ก็ยังไม่ได้อ่ะคับ มันบอกแบบข้างบนเลยอ่ะคับ ไม่รู้จาเซทไงดีแล้วอ่ะคับเนี่ย


ผู้ตอบคนที่ 1
ชื่อ: he
ส่งเมื่อวันที่ : 24 ธันวาคม, 1998 at 01:40:43 [ ด้วย IP 202.44.144.2 ]
หัวข้อ : Re: ยังเซทการ์ด network pci ไม่ได้เลยครับ .....
ตอบว่า :

พิม dump pnp ใน
root promt ดุนะคับจะมีวิธี insmod ne อยุ่
แล้วก้อทำตาม pnp.txt

ผู้ตอบคนที่ 2
ชื่อ: k
ส่งเมื่อวันที่ : 24 ธันวาคม, 1998 at 06:18:47 [ ด้วย IP 203.152.1.115 ]
หัวข้อ : Re: ยังเซทการ์ด network pci ไม่ได้เลยครับ .....
ตอบว่า :
พิม dump ที่ # แล้วนะคับ มันบอกว่าไม่มีคำสั่งนี้อ่ะคับ ลอง cat /proc/pci ออกมาก็นี่มันได้แบบนี้อ่ะครับ รู้สึกว่ามันเห็นการ์ดอ่ะครับ แต่ว่าเราโหลดโมดูลมันไม่ได้อ่ะครับ ลองใช้แผ่น net.i boot ดูมันก็ไม่เจออ่ะครับ อืม .. เศร้าจัง

PCI devices found:
Bus 0, device 11, function 0:
Ethernet controller: VIA Technologies Unknown device (rev 6).
Vendor id=1106. Device id=3043.
Medium devsel. IRQ 10. Master Capable. Latency=64. Min Gnt=118.Max Lat=152.
I/O at 0xe400.
Non-prefetchable 32 bit memory at 0xea000000.


ผู้ตอบคนที่ 3
ชื่อ: eiei
ส่งเมื่อวันที่ : 24 ธันวาคม, 1998 at 21:03:11 [ ด้วย IP 203.146.40.138 ]
หัวข้อ : Re: ยังเซทการ์ด network pci ไม่ได้เลยครับ .....
ตอบว่า :

gเรื่อง card network Koji เจ๋งคับ

ผู้ตอบคนที่ 4
ชื่อ: เรืองเดช
ส่งเมื่อวันที่ : 25 ธันวาคม, 1998 at 09:58:27 [ ด้วย IP 203.151.255.131 ]
หัวข้อ : Re: ยังเซทการ์ด network pci ไม่ได้เลยครับ .....
ตอบว่า :
ไม่ทราบจะกรณีเดียวกันหรือไม่ เพราะผมพึ่งจะลองใช้
พอดีผมใช้ linux Slackware ที่ซื้อจากของ NECTEC คงไม่ต่างกันมากนะครับ

ลองคอมไพล์ใหม่ซิครับ โดยเรียกใช้คำสั่ง
make menuconfig
แล้วไปลบเกี่ยวกับ Network card ของ 3Com ออก
แล้วกำหนดให้มันสนับสนุน PCI card ลองค้นหาเองนะครับ
แล้วเซฟคอนฟิกเหล่านี้ และทำการสั่ง

make dep; make clean
เมื่อเสร็จ สั่ง
make zImage
รอนานหน่อยนะครับ
เสร็จแล้ว ให้กอปปี้ไฟล์ /usr/src/linux/arch/i386/boot/zImage ไปไว้ที่ /boot
ควรจะสำรองไฟล์ตัวเดิมก่อนนะครับ
เสร็จแล้วใช้คำสั่ง
/sbin/lilo
พอบูตเครื่องใหม่ น่าจะเห็น PCI lancard นะครับ

ทั้งหมดนี้ผมไม่รับประกันความถูกต้องนะครับ เพราะสภาพเครื่องอาจไม่เหมือนกัน และผมก็อ่านเจอใน wwwboard นี้กับที่ //www.thailinux.org และที่อื่นๆ อีก แล้วมาทดลองดูเลยสำเร็จ

หวังว่าคงจะเซ็ตการ์ได้นะครับ โชคดี


ท่านผู้รู้ กรุณาช่วยตอบวิธีแก้ปัญหาให้หน่อยครับ ขอบคุณมากครับ :

ชื่อ :
E-Mail :
หัวข้อ :
ข้อความว่า :